Agente de comunicação não funciona após atualização

Assista ao vídeo e acompanhe o passo a passo abaixo!

  • Causa
Este problema ocorre quando o Agente de Comunicação ou o Serviço Domínio Atendimento estão em execução no Gerenciador de Tarefas no momento da atualização do sistema. Em ambientes de rede, o problema também ocorre quando a atualização é realizada nas estações de trabalho antes de ser concluída no servidor, o que gera incompatibilidade de versões.
 
  • Solução
Para corrigir o problema, encerre os processos do Agente de Comunicação e do Serviço Domínio Atendimento pelo Gerenciador de Tarefas e, em seguida, reinicie o Agente. Para evitar que o problema se repita, siga o procedimento preventivo descrito abaixo antes de cada atualização do sistema.
 
Importante! O procedimento a seguir deve ser realizado na máquina onde o Agente de Comunicação é iniciado, normalmente no servidor. Não é necessário realizar o procedimento nas demais máquinas.
 
Encerrar e atualizar Agente de Comunicação
1. No servidor, abra o Gerenciador de Tarefas com o atalho Ctrl + Shift + Esc;
2. Na guia Processos ou Detalhes, finalize os processos 'Agente_comunicacao.exe' e 'ServicoDominioAtendimento.exe';
3. Acesse o caminho C:\Contabil\Agente de Comunicação com o Domínio Atendimento\DownloadAgente e localize o arquivo InstalaAgente.exe;
4. Clique com o botão direito sobre o arquivo InstalaAgente.exe e selecione 'Executar como administrador';
5. Conclua a instalação conforme as instruções exibidas na tela;
6. Acesse o menu Iniciar do Windows e digite 'Agente de Comunicação', clique com o botão direito do mouse e selecione a opção 'Executar como administrador';
7. Na guia Inicialização, no quadro Iniciar/Parar comunicação com o Domínio Atendimento, clique no botão [Iniciar]. Quando for iniciado, o botão ficará desabilitado;
8. Verifique se o ícone está verde dentro do Sistema Domínio.
 
OBS: Caso durante a instalação seja exibida a mensagem "Erro ao tentar realizar um arquivo na pasta destino, código 183 - Não é possível criar o arquivo já existente", repita o encerramento dos processos descritos acima antes de executar novamente o instalador.
 
Informações Complementares
• Se você utiliza Domínio Web, por padrão o Agente de Comunicação já é atualizado e reiniciado periodicamente. Se mesmo assim apresentar um problema que necessite da reinicialização do Agente, entre em contato com o suporte técnico;
• Se não localizar algum destes processos ('Agente_comunicacao.exe' e 'ServicoDominioAtendimento.exe'), desconsidere-os.

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