Erro Importação Padrão: 'Erro ao buscar relacionamento de produtos'.

 
  • Causa
Este erro geralmente ocorre, quando o produto que está sendo importado, foi relacionado com mais de um produto já cadastrado dentro do sistema, ocasionando assim o erro. Esse relacionamento pode ser feito manual, ou ao importar a nota, e efetuando esse relacionamento essas informações ficam salvas no cadastro do produto na guia Importações > Saídas/SPED/Sintegra/OnBalance ou Importações > Entradas.
 
Importante!
O erro também pode ser apresentado como 'Problema com o banco de dados != (-1). Select returned more than one row.', de qualquer modo, os passos para correção são os mesmos demonstrados mias abaixo.
 
  • Solução
1 - Baixe o arquivo que está em anexo nesta solução, para isso no final dela clique no ícone ;
2 - Realize a importação dos arquivos BGRs para o sistema, caso tenha dúvidas de como instalar, clique aqui;
3 - Após instalar os arquivos BGRs, acesse a Escrita Fiscal novamente, caso a tela do 'Gerenciador de Relatórios' estiver aberta, feche e a abra novamente;
4 - Acesse o menu Relatórios e clique em Gerenciador de Relatórios;
5 - Localize a pasta Relatórios > Diversos, e clique em:
  • 'Relacionamento de Produtos', para ver os produtos que estão relacionados em duplicidade no menu Arquivos > Produtos > Importações > Entradas.
  • 'Relacionamento de Produtos Saídas', para ver os produtos que estão relacionados em duplicidade no menu Arquivos > Produtos > Importações > Saídas/SPED/Sintegra/OnBalance.
6 - Informe o código da empresa e clique em [Executar...] para emitir o relatório.
 
 
7 - Ao emitir o relatório, o sistema irá trazer o produto em duplicidade, e terá que avaliar qual relacionamento será excluído, conforme exemplo abaixo;
 
 
O produto '100133' do 'Fornecedor 12' está relacionado para o produto de código '1' e para o produto de código '2', com isso, ao importar a nota, o sistema não sabe se irá importar no código '1' ou no código '2', ocasionando assim o erro.
 
 
 
Exclusão Manual
1 - Acesse o menu Arquivos > Produtos, localize o produto que gostaria de excluir o relacionamento duplicado;
2 - Na guia Importações > Entradas ou Saídas/SPED/Sintegra/OnBalance, clique na linha que queira excluir caso tenha mais de uma, e em seguida clique no botão [Excluir];
3 - Clique no botão [Gravar] para concluir;
4 - Após realize a importação das notas novamente, verifique que o erro deixará de ocorrer e as notas serão importadas com sucesso.
 
Exclusão em Lote
1 - Acesse o menu Utilitário > Alterar Produtos > Excluir Relacionamento dos Produtos;
2 - No quado 'Tipo da configuração da importação', selecione uma das opções conforme a informação que deseja excluir '[x] Entradas' ou '[x] Saídas/SPED/Sintegra/OnBalance';
3 - Clique no botão [Buscar] e selecione os produtos no qual deseja excluir os códigos definidos em duplicidade, caso queira poderá clicar no botão [Busca avançada] e filtrar;
4 - Após clique no botão [Excluir relacionamento], será apresentada uma mensagem, clique em [Sim] para confirmar a exclusão;
 
 
5 - Realize a importação das notas novamente, verifique que o erro deixará de ocorrer e as notas serão importadas com sucesso.
 

Marcar todos como lidos