Erro Portal do cliente: 'Certificado com cadeia incompleta, favor inserir outro certificado'.

 
  • Causa
Esta mensagem é exibida quando o certificado não contém a cadeia completa de certificação (certificados raiz e intermediários das autoridades certificadoras). O erro ocorre ao tentar incluir certificado digital em Manifestação de NF-e > Habilitação de Clientes no ONVIO Portal do Cliente.
 
As autoridades certificadoras são entidades de confiança que garantem a autenticidade dos certificados digitais. Para realizar a manifestação da NF-e via Portal do Cliente, o certificado A1 deve incluir toda a hierarquia da cadeia de certificação.
 
  • Solução
Para corrigir este problema, será necessário exportar o certificado atual incluindo toda a cadeia de certificação através das configurações do Windows. O processo envolve exportar o certificado digital pelo Internet Explorer com as opções específicas que garantem a inclusão dos certificados intermediários e raiz. Após a exportação com a cadeia completa, o certificado antigo deve ser removido antes de incluir o novo no Portal.
 
Antes de começar
• Verifique se o certificado está instalado na sua máquina;
• Confirme que o certificado é do tipo A1 (arquivo .pfx);
• Tenha em mãos a senha do certificado.
 
Passo a passo
1. Acesse o menu Iniciar do Windows, pesquise por Opções da Internet e acesse-o;
2. Acesse a guia Conteúdo e clique no botão [Certificados];
 
 
3. Na guia Pessoal serão listados os certificados instalados;
4. Selecione o certificado do cliente que será adicionado ao Portal do Cliente e clique no botão [Exportar...];
 
 
5. Na janela Assistente para Exportação de Certificados, clique no botão [Avançar];
6. Selecione a opção '[x] Sim, exportar a chave privada' e clique no botão [Avançar];
 
 
7. Selecione a opção '[x] Troca de Informações Pessoais - PKCS nº 12 (.PFX,.P12)';
8. Marque obrigatoriamente as duas opções abaixo:
 
• '[x] Incluir todos os certificados no caminho de certificação, se possível'
• '[x] Exportar todas as propriedades estendidas'
 
 
9. Clique no botão [Avançar];
10. Na tela seguinte, selecione a opção '[x] Senha', informe uma senha e clique no botão [Avançar];
 
 
11. Clique no botão [Procurar...], informe o local onde deseja exportar/salvar o arquivo e no campo Nome informe um nome para esse arquivo;
 
 
12. Clique no botão [Salvar] e clique no botão [Avançar];
13. Para salvar as configurações, clique no botão [Concluir], onde será exibida a mensagem A exportação teve êxito;
14. Antes de usar o novo certificado no Portal, remova o certificado antigo:
 
• Volte em Opções de Internet > Conteúdo > Certificados
• Selecione o certificado antigo (sem a cadeia completa)
• Clique em [Remover]
 
15. Realize a inclusão do certificado recém-exportado no Portal do Cliente e avalie o resultado.
 
Opção Exportar chave privada desabilitada
Se a opção 'Sim, exportar a chave privada' estiver cinza/desabilitada no passo 6, siga estes passos:
 
1. Localize o arquivo original do certificado (.pfx) que você recebeu da certificadora;
2. Clique com o botão direito no arquivo > Instalar PFX;
3. Selecione Usuário Atual e clique em [Avançar];
4. Confirme o caminho do arquivo e clique em [Avançar];
5. Digite a senha do certificado;
6. Marque a opção '[x] Marcar esta chave como exportável';
7. Marque também '[x] Incluir todas as propriedades estendidas';
8. Clique em [Avançar] > [Avançar] > [Concluir];
9. Retorne ao passo 1 da solução principal acima.

Ainda não funcionou?
 
Se após seguir todos os passos o erro persistir, verifique:
 
• Se o certificado está dentro da validade;
• Teste em outro navegador (Chrome, Edge, Firefox);
• Limpe o cache do navegador;
• Verifique se há atualizações pendentes do Windows;
• Aguarde alguns minutos após a exportação antes de tentar incluir novamente no Portal.
 
Informações complementares
• O certificado digital incluído deve estar no formato .pfx;
• Mantenha a senha do certificado em local seguro;
• Após a exportação com a cadeia completa, sempre remova o certificado antigo antes de incluir o novo;
• Em alguns casos, pode ser necessário aguardar alguns minutos após a exportação para que o sistema reconheça o certificado corretamente;
• Salve o certificado exportado com a cadeia completa em um local de fácil acesso para futuras utilizações;
• Se após seguir todos os passos o erro persistir, entre em contato com sua certificadora (Serasa, Certisign, Valid, Soluti, etc.) e solicite um certificado digital A1 com cadeia completa de certificação, explicando que precisa incluir no ONVIO Portal do Cliente para manifestação de NF-e.

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