Erro eSocial: 'Erro ao assinar o evento: Não foi possível efetuar a assinatura do arquivo'

  • Causa
Este erro pode ocorrer nas seguintes situações:
1 - Quando o Certificado A1 é configurado como Certificado A3;
2 - Devido instabilidade entre os módulos e certificados ou existe algum caractere incorreto no nome amigável do certificado.
 
  • Solução 1
A mensagem pode ser apresentada quando o Certificado A1 é utilizado incorretamente como A3, para essa situação basta configurar o certificado corretamente e reenviar o evento, dessa forma:
 
1 - Selecione o evento invalidado e clique em [Excluir];
2 - Acesse a tela de cadastro do certificado digital utilizado:
• Caso seja da empresa Arquivo > Empresas;
• Caso seja do contador Arquivo > Contadores;
3 - Na guia Certificado Digital, selecione o Tipo de certificado correto e configure-o;
 
 
4 - Clique em [Gravar] e reenvie o evento.
 
  • Solução 2
Caso o certificado esteja configurado corretamente ou o erro persista após a configuração, realize os procedimento abaixo junto ao TI do escritório, pois podem ser realizadas alterações ou remoções de certificado digital e seus gerenciadores.
 
1 - Desconectar o certificado da máquina (Caso seja um cartão, remover também a leitora) aguardar de 3 a 5 minutos e reconectar o mesmo;
2 - Pressione as teclas WINDOWS + R,  informe MMC e clique no botão [Ok];
- Acesse o menu ARQUIVO, clique em ADICIONAR/REMOVER SNAP-IN;
- Selecionar o Snap-in CERTIFICADOS e clique em [Adicionar >];
 
 
- Selecione a opção '[x] Minha conta de usuário' e clique em [Concluir];
- Selecione novamente o Snap-in CERTIFICADOS e clicar em [Adicionar >];
- Selecione a opção '[x] Conta de computador' e clique em [Avançar];
- Selecione a opção '[x] Computador local' e clique em [Concluir];
- Após clique em [OK].
 
10 - Na pasta RAIZ DE CONSOLE;
11 - Navegue em CERTIFICADOS - USUÁRIO ATUAL, subpasta PESSOAL, subpasta CERTIFICADOS, excluir todos os certificados expirados (todos com data anterior ao dia de hoje);
12 - Navegue em CERTIFICADOS - COMPUTADOR LOCAL, subpasta PESSOAL, subpasta CERTIFICADOS, excluir todos os certificados expirados (todos com data anterior ao dia de hoje).
 
 
13 - No certificado em questão, de um "duplo-clique" e após acesse a guia DETALHES;
14 - Vá até a opção REQUERENTE e de um "duplo-clique";
15 - Após, selecione a opção CN e copie o nome completo do responsável pelo certificado (O nome após "CN=") e pressione as teclas "CTRL" + "C".
 
16 - Clique no botão [Editar Propriedades], e avalie o campo NOME AMIGÁVEL e DESCRIÇÃO;
17 - Em ambos os campos, caso tenha alguma nomenclatura preenchida deverá ser apagada, após deverá pressionar as teclas “Ctrl" + 'V”, onde o nome do responsável legal preencherá ambos os campos.
 
OBSA nomenclatura não poderá conter caracteres especiais (Ex: Acentos, símbolos, letras com acentuação e caracteres especiais comuns: ‘,~,&,”,^,ª) e com no máximo 40 caracteres, para que não haja problema ao identificar sua criptografia.
 
 
 
18 - Após corrigir, clique em [Ok], após [Ok] novamente;
 
Informações Complementares
• A tecnologia de certificação A3, utiliza um certificado físico, ou seja, o mesmo só funcionará quando a mídia estiver conectada ao computador em questão, desta forma o arquivo instalado no MMC, nada mais é do que uma mascará do certificado, sendo assim, no momento que o certificado é desplugado essa máscara é removida das configurações, fazendo assim com que o “nome amigável” alterado acima, volte a sua configuração original. 
Sendo assim, cada vez que o certificado for novamente plugado, os procedimentos de 6 a 7.1 deverão ser novamente realizados. Para que o procedimento não seja mais necessário, deverá avaliar junto a sua certificadora, para que a mesma configure corretamente o “nome amigável” no certificado raiz, ou seja, o certificado instalado dentro da mídia.
• Caso após remover a mídia física de seu computador, seja avaliado que a máscara do mesmo ainda esteja presente no MMC, deverá avaliar esta questão junto ao TI do escritório. Conforme indicado acima, o mesmo deve sair do MMC automaticamente no momento em que a mídia física é removida. Como paliativo, poderá excluir a máscara manualmente.
• Em alguns casos, o escritório configura o certificado do tipo A1 com a mesma nomenclatura do certificado A3, desta forma, caso realize o paliativo acima, avaliar se o certificado a ser excluído é o correto;
• Caso seu sistema operacional seja Windows 8 ou superior, prosseguir a partir do item 21.
 
19 - Navegue até a pasta CERTIFICADOS - USUÁRIO ATUAL, subpasta PESSOAL, subpasta CERTIFICADOS, selecionar o certificado com o nome do cliente que não é demonstrado no sistema e copiá-lo;
20 - Navegue até a pasta CERTIFICADOS - COMPUTADOR LOCAL, subpasta PESSOAL, subpasta CERTIFICADOS e colar;
21 - Salve o procedimento com o local e nome padrão (Poderá substituir caso exista um arquivo já salvo no local).
 
 
22 - Após, deverá acessar o link a baixo e avaliar com o certificado em questão se a a imagem será similar a imagem abaixo;
 
 
23 - Acesse o módulo Folha com o usuário GERENTE;
24 - Acesse o cadastro referente ao certificado em questão (Empresa ou contador);
25 - Avalie se o certificado será exibido normalmente.

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