Erro 157 eSocial: 'Evento de Exclusão ou Retificação deverá ser do mesmo tipo e se referir ao mesmo objeto do evento a ser excluído/retificado'

Assista ao vídeo e acompanhe o passo a passo abaixo!

  • Causa
Este erro ocorre ao enviar uma exclusão ou alteração de um evento e o eSocial não reconhece o evento que deseja retificar/excluir. 
 
  • Solução
Para essa situação, primeiro verifique em qual evento este erro ocorreu e siga os passos de acordo com a situação:
 
Erro ocorreu nos eventos de Admissão (S-2200/S-2300) ou Alteração (S-2205/S-2206/S-2306).
Nesse caso, a Matrícula eSocial ou o Número de Recibo estão diferentes entre Sistema e Portal eSocial. Para isso, compare o cadastro do colaborador no Sistema com o Portal do eSocial, e faça a correção de acordo com a informação diferente.
 
Matrícula eSocial diferente
1. Acesse o cadastro do colaborador que teve o evento invalidado;
2. No campo Matrícula eSocial, informe o mesmo número que consta no Portal eSocial;
3. Clique no botão [Gravar] e salve como [Correção/Retificação];
4. Faça o reenvio do evento e acompanhe a validação.
 
Número de Recibo diferente (validado manualmente)
1. No Portal do eSocial, no cadastro do colaborador, copie o número do recibo do evento;
2. Após retorne ao sistema, acesse e acesse o cadastro do colaborador;
3. Localize o colaborador e clique no botão [eSocial];
4. Na guia Validados, selecione o evento correspondente e que possui a validação Usuário e clique no botão [Editar];
5. Informe o mesmo número do recibo do Portal do eSocial e clique em [Gravar];
6. Faça o reenvio do evento e acompanhe a validação.
 
Erro ocorreu nos eventos Periódicos (S-1200 ou S-1210).
Nesse caso, dentro do Portal eSocial não foram localizados eventos de inclusão correspondentes aos eventos que deseja excluir ou retificar. Para isso, acesse Portal do eSocial e confirme se os eventos de remuneração e/ou pagamento da competência estão validados, caso não, siga os passos:
 
1. Acesse o Painel de Pendências do eSocial, selecione o evento invalidado e clique no botão [Excluir];
2. Em seguida, clique no botão [Validados], e na guia Periódicos, selecione o evento correspondente e clique no botão [Excluir] e confirme a exclusão;
3. Após, acesse o menu Relatórios > e-Social > Eventos periódicos;
4. Informe a Competência, selecione o evento e clique no botão [Enviar];
5. Acompanhe no Painel de Pendências do eSocial validação do evento.
 
Erro ocorreu nos eventos de afastamento temporário (S-2230).
Nesse caso, o erro ocorre ao enviar uma alteração de um evento que não foi localizado no Portal do eSocial. Para essa situação, o evento deve ser enviado com inclusão, dessa forma:
 
1. No Painel de Pendências do eSocial, selecione o evento invalidado e clique em [Excluir];
2. Acesse o menu Processos > Afastamentos, informe o código do colaborador;
3. Reenvie o evento de afastamento que foi invalidado.

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