Mensagem de erro: 'Problema com o banco de dados! = (-308), (-1) Connection was terminated' ou 'Conexão com banco de dados perdida'

 
  • Causa
Este erro ocorre quando a estação perde a comunicação com o servidor, entre os principais motivos estão:
 
- Banco corrompido;
- Falha no sistema operacional do servidor ou estação;
- Falha na rede do escritório, principalmente Wifi;
- Falha na instalação do sistema Domínio na estação ou servidor;
- Bloqueio por Firewall ou antivírus na estação ou servidor;
- Algum processo esta sendo interrompido pelo Windows;
 
  • Solução
Algumas configurações precisam ser realizadas evitar essas quedas.
 
Definindo parâmetros adicionais no servidor
Para realizar este procimento todos do escritório precisam estar fora do sistema pois será necessário parar o banco de dados, é indicado realizar no horario de almoço ou no início/final do expediente.
 
1 - No servidor do escritório abra o programa Gerenciar Servidor de Banco de Dados Execute como Administrador;
2 - Na tela de Gerenciar Servidor clique no botão [Parar] para parar o servidor;
3 - No campo Parâmetros adicionais Servidor informe ‘-ti0’ sem aspas;
4 - Clique em [Gravar] e posteriormente clique em [Iniciar] para iniciar o servidor novamente;
 
 
Configurando as opções do plano de energia dos computadores
Este procedimento é necessário para que em nenhum momento o servidor suspensa o processo de execução do banco de dados e as estações percam a conexão.
 
1 - Realize este procedimento em todas as máquinas, servidor e estações;
2 - Acesse o menu Iniciar do Windows e digite a palavra 'Energia' e entre nas 'Opções de energia';
3 - Será aberta a tela para você selecionar o Plano de Energia do computador;
4 - Marque a opção ‘[x] Alto desempenho’ e feche a janela;
 
 
7 - Adicione as regras abaixo de firewall e antivírus no servidor e nas estações:
 
OBS: Solicite ao TI do escritório realizar as liberações abaixo.
 
Regras de Saída 01: Programa do dbeng16.exe (normalmente fica no caminho C:\Program Files\SQL Anywhere 16);
Regras de Saída 02: Programa do dbsrv16.exe (normalmente fica no caminho C:\Program Files\SQL Anywhere 16);
Regras de Saída 03: Porta TCP de número 2638;
Regras de Saída 04: Porta UDP de número 2638. 
Regras de Entrada 01: Programa do dbeng16.exe;
Regras de Entrada 02: Programa do dbsrv16.exe;
Regras de Entrada 03: Porta TCP de número 2638;
Regras de Entrada 04: Porta UDP de número 2638.
 
Caso você tenha realizado os procedimentos, porém o problema ainda volte a ocorrer, será necessário o cadastro de uma solicitação de suporte. Para maior agilidade no processo de análise, cadastre o atendimento com as seguintes informações:
 
A - O erro ocorre em todas as estações?
B - Na estação, clicar em qualquer atalho do sistema domínio, na tela "Conectando...", clicar no botão "Reticências", clicar botão "Configurar" e retornar com imagem para análise.
C - No servidor, acessar menu "Iniciar", opção "Todos os programas", pasta "Servidor Domínio", selecionar "Gerenciar Servidor de Banco de Dados" e retornar com imagem para análise.
D - No servidor e estação acessar menu "Iniciar", clicar em "Painel de Controle", opção "Opções de Energia", encaminhar imagem da tela tanto do servidor quanto da máquina que demonstra o erro.
E - A rede do escritório é “sem fio” ou “Cabeada”?
F - Houve alguma queda de energia recentemente causando o desligamento das máquinas inesperadamente?”
G - Imagem do problema descrito;
H - O problema ocorre aleatoriamente ou em determinados momentos ou horários?
I - No servidor, acesse qualquer módulo, na janela de "Conectando..." clique no botão [...], selecione a conexão utilizada e clique em [Configurar...], retornar com imagem;
J - Iniciar um teste de ping conforme abaixo no servidor (ou na máquina onde o problema ocorre) até o memento do problema, após retorne com o TXT para avaliarmos. Para realizar o teste, seguir conforme abaixo:
J.1 - Pressione as teclas "Windows + R", digite CMD e pressione a tecla "Enter";
J.2 - Crie uma pasta "Teste_Ping" dentro de "C:";
J.3 - Dentro da janela CMD, digite a seguinte informação: ping www.google.com > c:\teste_ping\teste_ping.txt -t;
J.4 - Em seguida pressione "Enter" e aguardar até o momento em que o problema ocorrer;
J.5 - Nesta hora, poderá fechar a janela CMD e retornar com o arquivo "Teste_Ping.txt" criado dentro da pasta "Teste_Ping".

Marcar todos como lidos