Mensagem alteração produtos: 'Data do cadastro inválida!'

Assista ao vídeo e acompanhe o passo a passo abaixo!

  • Causa  
Essa mensagem ocorre quando a data de cadastro do produto está sendo alterada via utilitários, porém o período inicial da empresa é posterior à data de cadastro informada.
 
Exemplo: Se o período inicial da empresa é 01/2025 e você informa a data 01/2024, o erro ocorrerá.
 
  • Solução  
Para resolver, verifique o período inicial da empresa e ajuste a data de cadastro do produto para que seja igual ou posterior a esse período, conforme segue:
 
Parâmetros  
1. Acesse o menu Controle > Parâmetros;
2. Na guia Personaliza > Geral, no quadro Período, no campo Inicial, verifique o período inicial da empresa;
3. Após, clique no botão [Fechar].
 
Alterar Produtos  
1. Acesse o menu Utilitários > Alterar Produtos > Alteração de produtos;
2. Clique no botão [Buscar] ou [Busca avançada] e filtre ou selecione os produtos que deseja alterar;
3. Após, clique no botão [Alterar...];
4. No quadro Aplicar alteração para, selecione a opção '[x] Somente os produtos selecionados';
5. Na guia Geral, no quadro Dados cadastrais, selecione a opção '[x] Data do cadastro' e insira uma data igual ou posterior à de início da empresa;
6. Na guia Impostos, no quadro Vigência, selecione se deseja '[x] Alterar última vigência' ou '[x] Criar nova vigência';
7. Se selecionar '[x] Criar nova vigência', insira a Data e a Descrição da nova vigência;
8. Por fim, clique no botão [Alterar].

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