Mensagem na guia Invalidados: 'Erro 157 - Evento de Exclusão ou Retificação deverá ser do mesmo tipo e se referir ao mesmo objeto do evento a ser excluído/retificado'

Assista ao vídeo e acompanhe o passo a passo abaixo!

  • Causa
Esse erro ocorre nas seguintes situações:
 
• Quando a matrícula eSocial do colaborador está diferente entre Sistema e Portal;
No envio de Alterações (S-2205/S-2206/S-2306) de um colaborador que não possui essas informações no Sistema;
Quando o evento S-1210-Pagamentos não foi validado no eSocial e você está tentando Retificar ou Excluir esse evento. Isso costuma ocorrer quando o evento de pagamento foi enviado pelo Sistema, e depois foi excluído diretamente no Portal, com isso Portal e Sistema apresentam divergência de informações;
• Quando o evento S-2200 foi validado manualmente com número de recibo diferente do que consta no Portal do eSocial.
 
  • Solução
Realize os ajustes a seguir conforme a situação que gerou o erro:
 
Matrícula eSocial Diferente
1 - Acesse o menu Arquivo > Empregados / Estagiários / Contribuintes;
2 - Localize o colaborador que gerou o erro, e no campo Matrícula eSocial, informe exatamente o mesmo número conforme está no Portal eSocial;
3 - Clique na guia Pessoais > Endereço, e no campo Complemento, inclua ou altere alguma informação apenas para atualizar cadastro;
4 - Clique no botão [Gravar] e salve como [Retificação].
 
Alteração Contratual ou Cadastral
1 - Acesse o Painel de Pendências do eSocial, selecione o evento invalidado e clique no botão [Excluir];
2 - Acesse o cadastro do Colaborador (Empregado/Estagiário ou Contribuinte);
3 - Na guia Pessoais > Endereço, no campo Complemento, altere ou inclua um complemento do endereço;
4 - Esse procedimento é necessário apenas para reprocessar o cadastro do colaborador;
5 - Clique no botão [Gravar] e salve como [Retificação];
6 - Acompanhe no Painel de Pendências do eSocial validação do evento.
 
OBS: Quando realizada uma Alteração lembre-se de verificar se no botão [Histórico...] foi incluída uma nova linha correspondente a alteração, assim você evita possíveis erros.
 
Pagamento (S-1210) não validado no eSocial
Primeiramente, acesse o Portal do eSocial verifique se o evento S-1210-Pagamentos está validado;
Caso você tenha dúvidas sobre como realizar essa consulta, acesse: Consulta de Eventos no Portal do eSocial;
Após consultar o evento, caso ele não esteja validado no Portal, realize o seguinte procedimento:
 
1 - Acesse o Painel de Pendências do eSocial, selecione o evento S-1210 invalidado e clique no botão [Excluir];
2 - Após, acesse o menu Relatórios > e-Social > Eventos periódicos;
3 - Informe a competência, selecione a opção '[x] S-1210 - Pagamentos' e clique no botão [Enviar];
4 - Acompanhe no Painel de Pendências do eSocial validação do evento.
 
OBS: Caso após um dos ajustes anteriores o erro persista, no Painel de Pendências, avalie se o evento de Admissão foi validado manualmente e se foi informado o mesmo número de recibo, conforme Consulta no Portal do eSocial, caso não seja o mesmo número, acesse o cadastro do colaborador, clique no botão [eSocial], na guia Validados, selecione o evento de admissão e clique no notão [Editar], informe o número do recibo conforme consta no Portal e clique no botão [Gravar].
 
S-2200 validado manualmente
1 - Primeiro, acesse o Portal do eSocial e copie o número do recibo do evento S-2200 Admissão do empregado;
2 - Após retorne ao sistema, acesse Arquivo > Empregados;
3 - Localize o empregado e clique no botão [eSocial];
4 - Na guia Validados, selecione o evento S-2200 Admissão que possui a validação Usuário e clique no botão [Editar];
5 - Informe o mesmo número do recibo do Portal do eSocial e clique em [Gravar];
6 - Faça o reenvio do evento S-2200 Admissão e acompanhe a validação.

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