Ao acessar o sistema em apenas uma estação de trabalho ocorre a mensagem 'Erro -100 (O servidor do banco de dados não foi encontrado ou não está iniciado) Windows 7

  • Causa:
Quando temos apenas uma estação sem acesso ao servidor, possivelmente na configuração da conexão, o nome do servidor ou do banco de dados está incorreto, ou somente esta estação não está dentro da rede ao qual todas as demais estações(inclusive o servidor) estão. 
 
 
  • Solução:
1 – CONFIGURANDO ADMINISTRADO DE FONTE DE DADOS (ODBC):
 
1.1 – Antes de iniciar o processo você deverá verificar o número do ‘IP’ ou ‘NOME’ do seu servidor;
 
OBS: Caso você não tenha informação de IP ou Nome do Servidor, no computador servidor localize o ícone ‘Meu Computador’ e clique com o botão direito (auxiliar) do mouse sobre o ícone, na opção ‘Propriedades’, será aberta a tela de informações básica sobre o computador, no campo ‘Nome do computador’ estará à informação.
 
IMPORTANTE: Caso seu Sistema Operacional seja 64 bits, efetue o procedimento abaixo, caso seja 32 bits poderá ser ignorado e proceder do item 1.8 em diante. Para isso, clique aqui.
 
 
1.2 – Acesse o menu INICIAR do Windows na opção PAINEL DE CONTROLE;
 
 
 
1.3 – Clique na opção FERRAMENTAS ADMINISTRATIVAS;
 
 
1.4 – Na opção FONTE DE DADOS (ODBC) clique com o botão auxiliar (direito) do mouse;
1.5 – Selecione a opção PROPRIEDADES;
 
 
 
1.6 – No campo DESTINO informe o caminho C:\Windows\SysWOW64\odbcad32.exe e no campo INICIAR EM, informe o caminho: %windir%\SysWOW64 conforme imagem;
1.7 – Depois clique em [OK] e depois em [Aplicar];
 
 
 
1.8 – Após na estação com problema, acesse o botão Iniciar do Windows e na opção TODOS OS PROGRAMAS, ACESSÓRIOS, EXECUTAR, ou;
1.9 – Você poderá digitar também a palavra EXECUTAR no campo ‘Pesquisa programas e arquivos’;
1.10 – Ao abrir a tela EXECUTAR no campo abrir digite ‘odbcad32' e clique no botão [OK].
 
 
Nesta opção você irá configurar a Fonte de Dados, poderá variar entre Fonte da do Usuário ou Fonte de Dados do Sistema, de acordo com a conexão do seu banco de dados:
 
2 - FONTE DE DADOS DO USUÁRIO:
 
2.1 - Na tela ADMNISTRADOR DE FONTES DE DADOS ODBC clique na guia FONTE DE DADOS DE USUÁRIO;
2.2 – Verifique se no quadro ‘Fonte de dados usuário’ possui a conexão ‘Contábil – SQL Anywhere 16’ ou ‘Contabil – SQL Anywhere 9.0’ conforme seu banco de dados;
2.3 – Selecione a conexão e clique no botão [Configurar...].
 
 
 
3 - FONTE DE DADOS DE SISTEMA:
 
3.1 - Na tela ADMINISTRADOR DE FONTES DE DADOS ODBC clique na guia FONTE DE DADOS DE SISTEMA;
3.2 – Verifique se no quadro ‘Fonte de dados usuário’ possui a conexão ‘Contábil – SQL Anywhere 16’ ou ‘Contabil – SQL Anywhere 9.0’ conforme seu banco de dados;
3.3 – Selecione a conexão e clique no botão [Configurar...];
 
 
 
 Tela de configuração do ‘Contábil – Adaptive Server Anywhere 9.0’;
 
3.4 – Clique na guia REDE;
3.5 – Selecione a opção ‘[x] TCP/IP’ e informe o IP do servidor ou ‘Host=nome do seu servidor’;
3.6 – Informado os dados clique em [OK] para gravar;
 
 
Tela de configuração do ‘Contábil – Adaptive Server Anywere 16’;
 
3.7 – Clique na guia Rede ou Network;
3.8 – Na linha com nome ‘HOST’ na coluna VALOR informe o nome do servidor;
3.9 – Clique em [OK] para concluir;
 
 
1.23 – Retornando a tela anterior clique no botão [Aplicar] ou [OK] para concluir;
1.24 – Acesse o sistema normalmente e avalie o resultado.
 
Caso o problema persista, você deverá entrar em contato com o Departamento de Suporte de sua Região. Ao cadastrar um atendimento, para uma análise mais ágil, você poderá informar os seguintes dados:
 
1 - No servidor o acesso ocorre normalmente?
2 - Após clicar no botão [OK] para conectar-se ao sistema, a mensagem é emitida instantaneamente ou leva alguns segundos?
3 - No servidor, acessar o menu "Iniciar", submenu "Todos os programas", submenu "Servidor Domínio", opção "Gerenciar Servidor de banco de dados", salvar a imagem;
4 - Na máquina onde ocorre a mensagem, acessar o menu "Iniciar", clicar com o botão direito do mouse sobre a opção "Computador", acessar a opção "Propriedades", salvar a imagem;
5 - No servidor, acessar o menu "Iniciar", clicar com o botão direito do mouse sobre a opção "Computador", acessar a opção "Propriedades", salvar a imagem;
6 – Acessar a tela de Rede ou Network da configuração ODBC do procedimento 1.17 a 1.19 e
1.20 a 1.22, salvar as imagens;
7 - Na máquina onde ocorre a mensagem, acessar a tela de login do sistema, clicar em "...", posteriormente "Configurar", salvar a imagem;
8 – Anexar todas as salvas no atendimento.
 

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